Updating Packages

The FIT Server is modularly designed, which permits updates to specific packages independently of the overall system. When security updates for third-party components are published, for example for the bundled PHP, Sevenval usually promptly releases updated packages.

If you have used yum, zypper or aptitude for the initial setup, updates can be installed with yum update, zypper update or aptitude update; aptitude upgrade, respectively.

Otherwise, you have to download the updated packages from our download server and install them on the command line with rpm -U *.rpm or dpkg -i *.deb.

After each update of package files, you should stop all daemon processes, renew the configuration and restart the daemon processes. Finally, start a system check:

$ sbin/apachectl stop
$ sbin/phpfpmctl stop
$ bin/fitadmin config generate
$ sbin/phpfpmctl start
$ sbin/apachectl start
$ bin/fitadmin config check

If necessary, Sevenval also supplies updates for the PHP components of the FIT Server as extensions.

Cluster

In cluster operation, you have to repeat those steps on every single cluster node to install the new packages. To prevent outages, you should not update all cluster nodes in parallel, but one by one on the machines.

Apache httpd 2.4

FIT 14.1 no longer bundles the Apache Web server 2.2 but now instead simply supplies its own configuration files and start scripts for the Apache 2.4 web server provided by the distribution.

After the Apache package has been installed, your system may automatically start the Web server with the default system configuration. As this is probably not what you want, you have to stop the Web server manually after the package update has finished. You should also check whether the system Apache is automatically started at boot time and disable that if necessary.

If you have manually modified the configuration files, e.g. by adding files to include.global (including the templates supplied with FIT 14.0.x), or if you are using any httpd-conf sections in domains.conf.xml, ensure that the syntax is compatible with Apache 2.4. Please refer to the documentation on upgrading from the Apache Software Foundation, or contact Sevenval for assistance.

Among the changes is a new, more intuitive and flexible access control system, that replaces the Order, Allow and Deny statements. If your configuration relies on the old access control system, and you cannot update your configuration files, you may have to load the mod_access_compat module to re-enable the old system alongside the new.